Skocz do zawartości

Zdjęcie

DIY: Port AUX w fabrycznym radiu - kompendium

aux mp3 audio jack radio muzyka ipod iphone android telefon

  • Zaloguj się, aby dodać odpowiedź
39 odpowiedzi w tym temacie

#21
kaj1990

kaj1990

    Entuzjasta

  • Użytkownicy
  • 535 postów
  • SkądMilicz
Znalazłem na jakiejś aukcji na ebay że obsługuje od 9.55.

#22
yoyoal

yoyoal

    Nowicjusz

  • Użytkownicy
  • 3 postów

witam mam pytanie w sprawie pierwszego postu po poskładaniu całego zestawu (arduino) mam możliwość aktywowania tape lecz po podłączeniu telefonu nic nie słychać w głośnikach proszę pomożecie



#23
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

Musieli byśmy widzieć jak podłączyłeś wszystko żeby jakkolwiek to ocenić.

Jeżeli TAPE Ci się włącza to znaczy, że z arduino raczej ok bo radio rozpoznaje podłączony moduł. 

 

Pokaż jak przylutowałeś aux'a.



#24
yoyoal

yoyoal

    Nowicjusz

  • Użytkownicy
  • 3 postów

zdjęcie bez wlutowanego arduino

Załączone pliki



#25
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

No to tu w teorii dobrze. Czerwo i biały, sygnałowe do 15,13 i oplot w ziemię. 

Może jednak przy arduino coś źle połączyłeś... W jakość lutów nie wnikam bo średnio widać. To już Ty wiesz najlepiej czy zrobiłeś zimny lut czy nie.

 

Mogę niestety tylko zgadywać.

Z obrazka wygląda na dobrze.

 

Nie pomogę. :(



#26
yoyoal

yoyoal

    Nowicjusz

  • Użytkownicy
  • 3 postów

No to trudno w linku który był podany z zagranicznej strony w ostatnim poście też ktoś ma taki sam przypadek 



#27
maraswrona

maraswrona

    Bywalec

  • Użytkownicy
  • 89 postów
  • SkądKraków
  • Samochód:Mazdy: 323f (1998), 6 (2006), RX-8 (2006)

Z tego co piszesz wnioskuję że arduino działa. Sprawdziłbym sam kabel audio. Rozumiem że do portu z dołu przylutowałeś kabel z końcówką stereo, np jack? Spróbuj po kawałku to "zdebugować":

- włącz tape i podotykaj śrubokrętem końcówki jacka. w głośnikach powinny pojawić się trzaski

- jeśli nic nie ma, sprawdź same luty, dotknij pinów do których się przylutowałeś

- jeśli jest, to znaczy że kabel jest ok, ale pytanie czy dobrze wlutowałeś samą wtyczkę jack - są różne, czasem 3 albo 4 kanałowe, wyjście z telefonu obsługuje zazwyczaj jeszcze mikrofon, ogólnie nie wiem czy jest jakiś jednolity "standard" wlutowania się w jack tak żeby każdy telefon to obsłużył

- spróbuj podłączyć kabel nie do telefonu ale jakiegoś innego źródła dźwięku (stara mp3, laptop, discman)

 

Ciężko coś pomóc po omacku. Jak naprawdę nie będziesz w stanie tego rozwiązać, to zrób dokładne zdjęcia i wrzuć gdzieś razem z programem który wgrałeś na arduino. Może wypatrzymy jakiś problem.



#28
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

No co Ty gadasz wrona :)

Są standardy na wszystko!

 

Niżej na screenie przykład 4 kanałowego jacka.

Polecam apkę "electrodroid" na telefon. Tam jest wszystko czego do życia potrzeba. A najważniejsze to paski kodowe na rezystorach xD

Załączone pliki


Użytkownik Ravi edytował ten post 08 listopad 2018 - 14:10


#29
zima

zima

    Bywalec

  • Użytkownicy
  • 89 postów
  • SkądWarszawa
  • Samochód:RX-8
Ravi, 4 kanałowy jack to chyba ma pina z mikrofonem zamiast video.

znany wcześniej jako tomzz 😉

#30
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

Co podłączysz to ma.

Generalnie jak są 4 kanały to jest tak:

1-audio left

2-audio right

3-audio groud

4-aux

 

Do "auxa" dajesz co chcesz czy to mikrofon czy sterowanie czy co producent przewidzi.

 

Może być i video. W domu mam nawet przejściówkę z epoki cofania kaset ołówkiem, która z jednej strony ma RCA a z drugiej jacka 3.5mm.



#31
maraswrona

maraswrona

    Bywalec

  • Użytkownicy
  • 89 postów
  • SkądKraków
  • Samochód:Mazdy: 323f (1998), 6 (2006), RX-8 (2006)

@Ravi nie wiem czy pisałeś ironicznie czy na serio :) Twój obrazek pokazuje że standardy są, owszem, ale - tak jak przysłowiowy tyłek - każdy ma swój. Właśnie o to mi chodziło że co urządzenie to inaczej sobie układają tę kolejność pinów i potem ten sam jack może nie działać np w innym telefonie. 

 

@yoyoal, jak tam, poradziłeś sobie z problemem?



#32
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

@Ravi nie wiem czy pisałeś ironicznie czy na serio :) Twój obrazek pokazuje że standardy są, owszem, ale - tak jak przysłowiowy tyłek - każdy ma swój. Właśnie o to mi chodziło że co urządzenie to inaczej sobie układają tę kolejność pinów i potem ten sam jack może nie działać np w innym telefonie. 

 

@yoyoal, jak tam, poradziłeś sobie z problemem?

 

Trochę tak trochę tak. To samo podejście mam :D Jakaś organizacja zrobi standardy, a firmy sobie pozamieniają np. kolejność kanałów żeby działało tylko z "ich" słuchawkami (hello Apple :D). 



#33
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

@maraswrona - wsadziłem pro mini i też nie działa CD ;)

Możesz wyedytować posta pierwszego.



#34
maraswrona

maraswrona

    Bywalec

  • Użytkownicy
  • 89 postów
  • SkądKraków
  • Samochód:Mazdy: 323f (1998), 6 (2006), RX-8 (2006)

Ech, miałem wrócić do tego tematu w zeszłym roku ale ciągle brak czasu :)

 

Z czego zasilasz pro mini? Wydaje mi się że linia 12v bezpośrednio z auta ma jakieś spadki napięć, które powodują restart / zawieszanie się arduino, ale to tylko hipoteza. Chciałem zrobić osobne stabilizowane zasilanie 5V i to sprawdzić, no ale brak czasu panie, na wszystko brak czasu...



#35
Yaro

Yaro

    Dyskutant

  • Użytkownicy
  • 213 postów
  • SkądWarszawa
  • Samochód:RX8 HP

Ech, miałem wrócić do tego tematu w zeszłym roku ale ciągle brak czasu :)

 

Z czego zasilasz pro mini? Wydaje mi się że linia 12v bezpośrednio z auta ma jakieś spadki napięć, które powodują restart / zawieszanie się arduino, ale to tylko hipoteza. Chciałem zrobić osobne stabilizowane zasilanie 5V i to sprawdzić, no ale brak czasu panie, na wszystko brak czasu...

 

 

Standardowe arduino nie lubi napięć powyżej 12v, a w aucie pojawia się nawet 14v.

 

Chyba lepiej zrobić zasilanie 5v np z jakiejś zasilacza USB.



#36
Ravi

Ravi

    Entuzjasta

  • Użytkownicy
  • 619 postów
  • SkądWarszawa
  • Samochód:Mazda RX-8 2004 HP

Ech, miałem wrócić do tego tematu w zeszłym roku ale ciągle brak czasu :)

Z czego zasilasz pro mini? Wydaje mi się że linia 12v bezpośrednio z auta ma jakieś spadki napięć, które powodują restart / zawieszanie się arduino, ale to tylko hipoteza. Chciałem zrobić osobne stabilizowane zasilanie 5V i to sprawdzić, no ale brak czasu panie, na wszystko brak czasu...


Tak jak w oryginale pod pin 11 czyli accesory power switched 12v
Może pomogłoby wlutowanie się w w piny 3/4 gdzie jest stabilne 12v, ewentualnie jak mówisz zrobienie stepdowna na 5V.

#37
maraswrona

maraswrona

    Bywalec

  • Użytkownicy
  • 89 postów
  • SkądKraków
  • Samochód:Mazdy: 323f (1998), 6 (2006), RX-8 (2006)

oo widzisz, te 14V to też jakiś trop. Ale bardzo łatwo to zestabilizować do 5V, wystarczy taki najprostszy L7805 https://botland.com....-tht-to220.html + do tego 2 kondensatory po 10uF i masz eleganckie 5V. 


Użytkownik maraswrona edytował ten post 18 luty 2019 - 11:52

  • Ravi lubi to

#38
Darko

Darko

    Zapaleniec

  • Użytkownicy
  • 1339 postów
  • SkądGniezno
  • Samochód:Rx 8 HP
Panowie jak co to można zrobić sterowanie z kierownicy w radiu tzn. jak by ktoś przerabial konsolę i wywalił radio seryjne i wstawił inne.

#39
Koovert

Koovert

    Amator

  • Użytkownicy
  • 26 postów
  • Samochód:RX-8 HP z '04

Hej!
 

Wiem, że temat stary natomiast w kwestii czteropolowych jacków: idąc od przodu jest lewy/prawy, a potem jest wolna amerykana uziemienie albo mikrofon: trrs-diagram3.jpg

 

I swego czasu do czegoś potrzebowałem inwerter tych 2 ostatnich, bo mi się standardy nie zgadzały. Kabel "przerabiał" jedną kolejność na drugą.

 

 

A w temacie tego modułu co chciałem kupić: zero odpowiedzi od gościa. 8-(



#40
Terro84

Terro84

    Nowicjusz

  • Użytkownicy
  • 1 postów
Odkopie temat. Ma ktos pomysl pod adapter bluetooth do radia rlori rexa ver.9.55

Wysłane z mojego M2012K11AG przy użyciu Tapatalka





Również z jednym lub większą ilością słów kluczowych: aux, mp3, audio, jack, radio, muzyka, ipod, iphone, android, telefon

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych

Seo katalog stron darmowy